Archive for June, 2012

Presenting… the SharePoint Admin Nav Console (SPANC)

Written by Cornelius J. van Dyk on . Posted in Blog

YouTube Demo If you’re like me, you’ve never really tamed the beast called SharePoint Central Admin. With every version, the UI is changed around and it’s not a site administrators go to frequently enough to allow them to get to know the site inside out. The first seed for SPANC was planted about 6 years ago when I was on site with a client and I was hunting through the options in CA for (then) SharePoint Portal Server 2003. The client just looked at me in that certain way. He didn’t say anything, but I could sense what he was thinking and I envisioned it to be something like this… “Hey, you’re a SharePoint MVP and you don’t know your way around CA?” We all know the answer to that. Yes I do, but I don’t know it blind folded. True enough, there are a select few who can remember where every single link in CA is, but that’s not me. I figure I probably do something in CA maybe 9 times per day. In my own rough testing, I calculated that SPANC saves me about 6 seconds per command I’m searching for. Multiply that over 200 work days a year and we get: 9 x 6 x 200 = 10,800 seconds saved per year or better yet, 180 minutes or 3 hours!!! What could you do with 3 extra (BILLABLE) hours per year? I’ve come to a place in life where I know that time is our most precious commodity and every second counts. All philosophical notions aside, SPANC saves me lots of subtle frustration in CA and that’s why I built it. Winking smile Get it here

Cheers
C




image

How do I – Resolve the issue where the Term Store Management option does not show up in Site Settings for a SharePoint site

Written by Cornelius J. van Dyk on . Posted in How Do I...

A friend of mine pinged me the other day asking about the Term Store. The problem he was seeing was that the “Term store management” link wasn’t showing up under the Site Administration section of the site. He had another site in the same web application that did show the link so the question was why this site did not show the link. When looking at the Site Settings page for the site in question, we saw this: image3_thumb_399679A7 Wondering if this was another of SharePoint’s hide-and-seek games (like hiding the Delete Site link), I entered the direct URL to the Term Store into my browser. The direct URL is located as /_Layouts/termstoremanager.aspx Of course, I did not get the Term Store, but instead was confronted with the wonderful CorrelationID page. Nonetheless, now that I had a CorrelationID, I had a log I could look to for more information. Upon inspection of the ULS log file, this is what I found:

05/30/2012 09:40:26.47 w3wp.exe (0x3AE4) 0x35E0     SharePoint Foundation  Logging Correlation Data  xmnv  Medium      Name=Request (GET:http://workspaces.crayveon.com:80/ZBI/_Layouts/termstoremanager.aspx)  a7de1d35-c1ba-467b-9099-492693dcd124
05/30/2012 09:40:26.83 w3wp.exe (0x3AE4) 0x35E0     SharePoint Foundation  Logging Correlation Data  xmnv  Medium      Site=/ws/ZBI  a7de1d35-c1ba-467b-9099-492693dcd124
05/30/2012 09:40:26.95 w3wp.exe (0x3AE4) 0x35E0     SharePoint Foundation  Runtime                   tkau  Unexpected  System.InvalidOperationException: The Taxonomy feature (Feature ID "73EF14B1-13A9-416b-A9B5-ECECA2B0604C") has not been activated.
    at Microsoft.SharePoint.Taxonomy.OM.CodeBehind.TermStoreManager.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)    a7de1d35-c1ba-467b-9099-492693dcd124
05/30/2012 09:40:26.97 w3wp.exe (0x3AE4) 0x35E0     SharePoint Foundation  Monitoring                b4ly  Medium      Leaving Monitored Scope (Request (GET:http://workspaces.crayveon.com:80/ZBI/_Layouts/termstoremanager.aspx)). Execution Time=501.213422376308    a7de1d35-c1ba-467b-9099-492693dcd124
As always, the most important line is the first one of type “Unexpected” following the first reference of your CorrelationID. In this case, the issue is easily identified as: The Taxonomy feature (Feature ID “73EF14B1-13A9-416b-A9B5-ECECA2B0604C”) has not been activated. Now the solution was easy, right? Simply activate the Taxonomy Feature on the site or site collection and you’re all set. Not so fast… The Taxonomy Feature is a hidden Feature. As such, this Feature is activated via the Taxonomy Feature Stapler which is attached with most site templates. The keyword is MOST. This stapler is NOT attached to the BLANK SITE TEMPLATE. The reason for this is because there’s a site attribute called “AllowGlobalFeatureAssociations” which is set to false on blank site templates. Because of this, the Feature Stapler will not fire upon the creation of the blank site and as a result, Taxonomy will not work on the site. So how do we solve that? Unfortunately, you’re going to need console access which is a problem for hosted environments such as SharePoint Online in Office 365. If however you have rights and access to your server, it can easily be done through the following Powershell cmdlet:
Enable-SPFeature -identity "73EF14B1-13A9-416b-A9B5-ECECA2B0604C" -url 

Of course if you're still old school and want to use STSADM, you can still do that by using this command:

STSADM -o activatefeature -id "73EF14B1-13A9-416b-A9B5-ECECA2B0604C" -url  –force
Once you’ve activated the Feature, a refresh of the Site Administration page shows: image_thumb_399679A7

Cheers
C




image